Adobe Camera Raw 5.2 for CS4 only

As expected, Adobe has again ‘broken’ the continuity of support for users of earlier versions of their Photoshop CS and Elements programs; the new ACR release to handle the forthcoming EOS 5D Mark II (which Canon tell us is not likely to be on sale in the UK before January) will require an upgrade to CS4 (minimum £300 in the UK) or Elements (no upgrade path offered, just buy a new copy every time they do this). Lightroom users, as has happened before, must wait for their own update.

Continue reading